close
0

Could not find a version that satisfies the requirement

avatar
asked 02-09-2022

4 Answers


0

Upgrade Setuptools by running this command

pip install --upgrade setuptools

And then Upgrade pip by running this command

python -m pip install --upgrade pip

And Now You can install any pip packages without any error. Just like this.

python3 -m pip install <your_package_name>

Now Your error will be solved

avatar
answered 02-09-2022

0

If You are facing this error while installing requirement.txt then You should consider to use -r flag. Just Like this.

pip install -r requirements.txt
avatar
answered 02-09-2022

0
python3 -m pip install <pkg>
avatar
answered 02-09-2022

0
python3.10 -m pip install <pkg>
avatar
answered 02-09-2022